您好,欢迎访问这里是深圳市硕远科技有限公司!
戴尔服务器价格_IBM联想配置_浪潮代理-深圳市硕远科技有限公司
联系我们
戴尔服务器价格_IBM联想配置_浪潮代理-深圳市硕远科技有限公司
邮箱:2324898850@qq.com
电话:400-080-6079
地址:深圳市龙华区河背工业区108创业园A301
当前位置:主页 > 新闻动态 > 行业新闻 >

行业新闻

配置交换机设备作为 DHCP 服务器

发布时间:2022-04-25 20:00:05浏览次数:


要求:某企业为办公电脑规划了两个网段,网段192.168.10.0/24内PC为员工固定办公电脑,网段192.168.20.0/24供企业出差人员临时接入网络。企业希望通过DHCP方式为员工固定办公终端和企业出差人员分配IP地址。其中,企业管理者的办公PC1(Client_1)由于业务需要,希望使用固定IP地址为192.168.10.100/24。保留192.168.10.1-192.168.10.10的10个地址不动态分配。

重播 播放 00:00 / 00:00 正在直播 00:00 进入全屏
    点击按住可拖动视频

    一、本节知识点:

    动态主机配置协议DHCP(Dynamic Host CÑnfigñr†ì²Ñn Protocol)采用客户端/服务器模式对用户的网络参数进行动态配置和集中管理。其中,DHCP服务器通过地址池为用户分配IP地址等网络参数。地址池分为接口地址池和全局地址池两种。

    接口地址池配置方式简单,只能用于用户与DHCP服务器在同一个网段的场景,并且只能给对应接口下的用户分配IP地址等网络参数;适用于设备数量有限、配置以及维护量可控的小型网络。在用户网关设备上配置基于接口地址池的DHCP服务器功能之后,对应接口下的固定主机、移动终端等都可以自动获取IP地址等网络参数,不需要用户手动配置修改。 与接口地址池相比,全局地址池可应用于大型网络,推荐在核心层设备上配置基于全局地址池的DHCP服务器功能或在服务器区域搭建一台专门的DHCP服务器统一分配IP地址等网络参数,而用户网关设备上只需要启用简单的DHCP中继功能即可。

    二、配置思路:

    通过在网关设备SW1上配置DHCP服务器,实现为企业两个网段内的终端动态分配IP地址。其中,网段192.168.10.0/24内的PC为员工固定办公终端,IP地址租期配置为30天;网段192.168.20.0/24供企业出差人员临时接入网络,IP地址租期配置为1天。 为管理者PC的分配固定的IP地址192.168.10.100/24。保留192.168.10.1-192.168.10.10的10个地址不动态分配。

    二、IP设置:

    所有的PC机为DHCP动态获取IP地址

    VLANif10:192.168.10.254/24 ,vlan10

    VLANif20:192.168.20.254/24 ,vlan 11

    四、SW1交换机的主要配置文件:

    #

    sysname SW1

    #

    vlan batch 10 20

    #

    dhcp enable //启用DHCP服务器功能

    #

    interface Vlanif10 //创建vlanif10三层接口

    ip address 192.168.10.254 255.255.255.0 //设置IP地址

    dhcp select interface //启用接口地址池方式

    dhcp server excluded-ip-address 192.168.10.1 192.168.10.10 //设置不用于分配的地址

    dhcp server static-bind ip-address 192.168.10.100 mac-address 5489-98a8-6da0 //将MAC地址的IP地址绑定,即交换机发现这个mac地址的计算机就直接分配192.168.10.100地址

    dhcp server lease day 30 hour 0 minute 0 //分配地址的租期为30天

    #

    interface Vlanif20

    ip address 192.168.20.254 255.255.255.0

    dhcp select interface

    #

    interface MEth0/0/1

    #

    interface GigabitEthernet0/0/1

    port link-type trunk

    port trunk allow-pass vlan 10

    #

    interface GigabitEthernet0/0/2

    port link-type trunk

    port trunk allow-pass vlan 20

    #

    return

    接入交换机的主要配置文件:

    #

    sysname Huawei

    #

    vlan batch 10

    interface Ethernet0/0/1

    port link-type access

    port default vlan 10

    #

    interface Ethernet0/0/2

    #

    interface Ethernet0/0/3

    port link-type trunk

    port trunk allow-pass vlan 2 to 4094

    #

    return

    五、验证配置结果:

    1、在pc机上用ipconfig命令查看本机的IP地址。

    400-080-6079